Eclipse Android Development Tools requires ‘org.eclipse.ui 3.6.2′ error solution

Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires ‘org.eclipse.ui 3.6.2′ but it could not be found

If you have encountered above error while updating the android sdk or while trying the Android SDK setup on Eclipse Galileo.
You will need at least Eclipse Helios on your system to solve this problem, better to get latest Eclipse version. I have downloaded the Eclipse Indigo and Android ADT installation worked smoothly.

Please go to http://www.eclipse.org/downloads/ and download Eclipse classic, choose win32/64 as per your platform.

Let me know if this works!

Please delete your old workspace before starting the newly downloaded Eclipse instance.


Sameer is a Internet technology Blogger from India. He is currently working in Mobile domain. He love to explore latest technology trends in mobile application development and Internet.

15 Responses to “Eclipse Android Development Tools requires ‘org.eclipse.ui 3.6.2′ error solution”

  1. regifraga says:

    Hi Sameer, how is it going?

    I was trying do this at lest 3 houres and always I got problem. But you showed me what I was doing wrong. Thanks a lot.

    Take care,
    Regivaldo Fraga

  2. […] いろいろググって、私と同じような現象があったので早速試してみました。 ここにADT Plugin for […]

  3. Corbin says:

    Yeah I have been trying to solve this problem for days. I have indigo and helios on my machine. I’m not sure if they are “properly installed ” I have downloaded the zip files and extracted them to a place in my C drive. The programs will run but never ran a install. I have even tried downloading the zip of the ADT plugin and installing from that with no luck. I am very frustrated with this whole process. I have had plenty of experience with C++ so i thought i would try my hand with some Android Apps. I can’t even get the plugin installed correctly. When I try to install the ADT plugin I get the following errors “Cannot complete the install because one or more required items could not be found.
    Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534)
    Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires ‘org.eclipse.ui 3.6.2′ but it could not be found ”
    Which is the farthest I have gotten. I have downloaded the AVD and the SDK and the SDK gives me the file cannot be found and nothing was installed error, that access is denied . Please any help would be greatly appreciated.

    • Sameer says:

      Hi Corbin,
      ADT plugin should get installed properly first, If you are working on latest Eclipse Indigo then by adding this url to external sources should solve your problem. Try with http instead of https, and are you sure you are not working behind any proxy?
      Once ADT get installed properly giving the latest extracted sdk folder path will do the android setup complete. Also try to uninstall or remove other instances of the Eclipse.

      • android says:

        Well, would you be so kind as to tell how to install android adt if one is behind a proxy server?

        • Sameer says:

          Try setting proxy in eclipse as below:
          1. go to Window -> prefrences -> General -> Network connections
          2. Change Active provider to Manual
          3. Enter the proxy setting for HTTP, HTTPS and SOCKS.
          4. Apply the settings
          4. Restart Eclipse

  4. Jake says:

    Thanks for the heads-up!

    Upgraded to 3.7 basic and it worked.

  5. FustratedByEclipse says:

    Is it just me or is eclipse the buggiest thing since a Brooklyn Apt?
    download helios fresh install after giving up on galileo.
    go to install new software from the helios menu .

    An internal error occurred during: “Install download2″.

    java.lang.IllegalArgumentException: Comparison method violates its general contract!
    at java.util.ComparableTimSort.mergeLo(Unknown Source)
    at java.util.ComparableTimSort.mergeAt(Unknown Source)
    at java.util.ComparableTimSort.mergeCollapse(Unknown Source)
    at java.util.ComparableTimSort.sort(Unknown Source)
    at java.util.ComparableTimSort.sort(Unknown Source)
    at java.util.Arrays.sort(Unknown Source)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorSelector.hasValidMirror(MirrorSelector.java:317)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:517)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:576)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.getArtifact(MirrorRequest.java:248)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transferSingle(MirrorRequest.java:223)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transfer(MirrorRequest.java:179)
    at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.perform(MirrorRequest.java:115)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:565)
    at org.eclipse.equinox.internal.p2.artifact.repository.simple.DownloadJob.run(DownloadJob.java:63)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

  6. jacob says:

    Thank You,
    I have been stuck with this problem for a long time. You have saved me so much time.

  7. lynnlin says:

    down load the new Eclipse SDK, so i have to reinstall other plugins?? like SVN plugin,jira plugin and so on??

  8. Diego says:

    This problem sometimes can be resolved deleting all contents of Workspace folder… (make sure to backup your data first), afther do taht restar eclipse and try install again.

  9. Raviteja says:

    Hi Sameer, I am getting below error, i tried alot to overcome this but not able to solve.

    Cannot complete the install because one or more required items could not be found.
    Software being installed: Android Hierarchy Viewer 20.0.2.v201207191942-407447 (com.android.ide.eclipse.hierarchyviewer.feature.group 20.0.2.v201207191942-407447)
    Missing requirement: Android Hierarchy Viewer 20.0.2.v201207191942-407447 (com.android.ide.eclipse.hierarchyviewer.feature.group 20.0.2.v201207191942-407447) requires ‘org.eclipse.core.runtime 3.6.0′ but it could not be found

    Can you please tell me the solution for this?

    • Sameer says:

      From the errors it seems that you are using old eclipse version. Latest ADT requires eclipse 3.6.2 or higher. You can update to latst Eclipse Juno. Let me know if it works.

Leave a Reply

© 2017 MobiTechie. All rights reserved. Site Admin · Entries RSS · Comments RSS
Powered by WordPress · Designed by Theme Junkie